Webhosting voor Developers

Het internet veranderd en hierdoor ook de traditionele webhosting zoals wij dat vroeger kende, toen maakte je een website vaak in HTML/CSS en dit werkte je uit via een kladblok of notepad-editor(zoals Notepad+) waarna je dit uploaden naar een FTP Server en je website live was.

Anno 2017 wordt er steeds meer gewerkt met SSH (Secure Shell) hiermee kun je inloggen op een hosting via een versleutelde verbinding en d.m.v commando`s verschillende taken uitvoeren, dit varieeerd van het aanmaken van bestanden tot het direct bewerken van bestanden (via VIM of NANO) dat is nog vrij simpel gezegd wat het kan meer, veel meer.

Mogelijkheden van SSH

Dankzij SSH hebben web-developers de mogelijkheden om dagelijkse taken beter te kunnen uitvoeren, zo kan er worden gewerkt met versie-beheer via Git repositories (zoals GitHub),  maar ook library/framework/dependency beheer met Composer waarmee het onderhouden van PHP een stuk sneller & beter kan.

Wij van Hostingwalk bieden onder onze Business Hosting pakketten ook WP-CLI hiermee kunt u via SSH uw WordPress applicaties beheren, met een simpel commando ($ wp plugin install rest-api --activate)  kun je bijvoorbeeld de plugin rest-api installeren, en deze direct activeren zodat hij gebruiksklaar is.

Kies zelf welke PHP versie je wilt draaien per website

Via ons controlpanel kunt u zelf kiezen welke versie uw website moet draaien u heeft de keuze uit:   PHP 5.1 / 5.2 / 5.3 / 5.4 / 5.5 / 5.6 / 7.0 / 7.1!  hiernaast heeft u nog de keuze welke PHP extensies u wilt activeren zoals  PDO of MySQLi en caching technieken zoals redis en opcache.

Gratis SSL Certificaten dankzij Lets Encrypt!

In drie klikken kunt u zonder onze hulp een SSL certificaat installeren voor uw domein of sub-domeinnaam, elk certificaat wordt automatisch uitgegeven en verlengd.

Grote bedrijven als Google, Facebook, Mozzila en de Linux Foundation staan achter Lets Encrypt waardoor u zekerheid heeft dat uw SSL certificaat in vrijwel iedere browser werkt.

Daarnaast heeft de laatste versie van Firefox een melding van niet veilig indien een login pagina geen HTTPS meer heeft.